Project

General

Profile

Bug #24165

python3-lasso de stretch-eobuilder impose python < 3.6, installation impossible sur buster et suivantes

Added by Thomas Noël over 1 year ago. Updated 5 months ago.

Status:
Solution déployée
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
30 May 2018
Due date:
% Done:

0%

Patch proposed:
No
Planning:
No

Description

c'est lié à debian-stretch/control qui se base sur les dépendances de Stretch :

Package: python3-lasso
Section: python
Architecture: any
Depends: ${python3:Depends}, ${shlibs:Depends}, ${misc:depends}
...

History

#1 Updated by Thomas Noël over 1 year ago

On pourrait :
  • soit lancer eobuilder pour buster
  • soit trouver comment retirer le "Depends: python3 (<< 3.6), ..." généré par le ${python3:Depends}

#2 Updated by Frédéric Péters over 1 year ago

Ou rien du tout et simplement utiliser le python3-lasso officiel de Debian ? (c'est ce que je fais)

(et oui ça serait bien d'avoir une nouvelle version de lasso, qu'elle puisse être envoyée dans debian)

#3 Updated by Thomas Noël over 1 year ago

Frédéric Péters a écrit :

Ou rien du tout et simplement utiliser le python3-lasso officiel de Debian ? (c'est ce que je fais)

Oui, ce que j'ai fait aussi finalement, comme Elias et Emmanuel. Je me disais juste que cela nous permettrait de manger notre propre nourriture et d'éventuellement lever des soucis avec le lasso d'eobuilder.

#4 Updated by Benjamin Dauvergne over 1 year ago

J'ai release une 2.5.99 pour release d'une 2.6.0 finale, si j'ai de la chance John Dennis regardera sinon ce sera free style.

#5 Updated by Benjamin Dauvergne over 1 year ago

  • Target version set to 2.6.1

#6 Updated by Benjamin Dauvergne over 1 year ago

Est-ce que la version 2.6.0 a amélioré les choses ici ?

#7 Updated by Benjamin Dauvergne over 1 year ago

Je réponds tout seul, oui le paquet est bon sur buster (mais il contient les bugs corrigés récemment sur master).

Donc release 2.6.1, nécessaire, je passe le ticket en résolu à déployer parce que ça dépend maintenant de la release 2.6.1.

#8 Updated by Benjamin Dauvergne over 1 year ago

  • Status changed from Nouveau to Résolu (à déployer)

#9 Updated by Benjamin Dauvergne 5 months ago

  • Status changed from Résolu (à déployer) to Solution déployée

Also available in: Atom PDF