Project

General

Profile

Bug #31482

limiter la dépendance django-jsonfield à < 1.1 pour rester sur une version compatible avec django 1.8

Added by Frédéric Péters 8 months ago. Updated 8 months ago.

Status:
Solution déployée
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
16 Mar 2019
Due date:
% Done:

0%

Patch proposed:
Yes
Planning:
No

Description

cf https://jenkins2.entrouvert.org/job/hobo/261/consoleFull

authentic2.plugins.PluginError: ('unable to load entrypoint authentic2-auth-ssl = authentic2.auth2_auth.auth2_ssl:Plugin', ContextualVersionConflict(Django 1.8.19 (/tmp/tox-jenkins/hobo/coverage-django18-authentic/lib/python2.7/site-packages), Requirement.parse('Django>=1.9'), set(['django-jsonfield'])))

0001-misc-limit-django-jsonfield-version-to-keep-django-1.patch View (736 Bytes) Frédéric Péters, 16 Mar 2019 05:53 PM

Associated revisions

Revision 12c4abbc (diff)
Added by Frédéric Péters 8 months ago

tox: limit django-jsonfield version to keep django 1.8 compatibility (#31482)

Revision 80456959 (diff)
Added by Frédéric Péters 8 months ago

tox: limit django-jsonfield version to keep django 1.8 compatibility (#31482)

History

#1 Updated by Frédéric Péters 8 months ago

#2 Updated by Frédéric Péters 8 months ago

  • Status changed from Solution proposée to Résolu (à déployer)

J'ai revu ça pour ne pas toucher au setup.py, seulement au tox.ini et pour le build en 1.8, et j'ai poussé.

commit 12c4abbc7b93a50bf070d19ddb205adeeb9424e2
Author: Frédéric Péters <fpeters@entrouvert.com>
Date:   Sat Mar 16 17:52:24 2019 +0100

    tox: limit django-jsonfield version to keep django 1.8 compatibility (#31482)

#3 Updated by Frédéric Péters 8 months ago

  • Status changed from Résolu (à déployer) to Solution déployée

Also available in: Atom PDF