Project

General

Profile

Bug #42299

PHP7 binding in CentOS 8

Added by Clément Oudot almost 3 years ago. Updated over 1 year ago.

Status:
Fermé
Priority:
Normal
Assignee:
-
Category:
Binding php
Target version:
-
Start date:
29 April 2020
Due date:
% Done:

0%

Estimated time:
Patch proposed:
Yes
Planning:
No

Description

Hello,

I tried to build packages for CentOS 8 and had an issue with PHP 7 binding. I join a patch that worked to fix this.

Hope it helps.


Files

php7-binding-centos8.patch (768 Bytes) php7-binding-centos8.patch Clément Oudot, 29 April 2020 09:56 PM

Associated revisions

Revision 15b8cd7a (diff)
Added by Benjamin Dauvergne over 2 years ago

configure.ac: support php7 interpreter on CentOS 8 (#42299)

History

#1

Updated by Clément Oudot almost 3 years ago

It appears my patch is incomplete, here is a better patch: https://src.fedoraproject.org/fork/xavierb/rpms/lasso/blob/8c19070224fc32ccf59c72173fc6014ca614a1fd/f/lasso-2.6.1-fix_php7_discovery.patch

It is not specific to CentOS 8, Fedora is also impacted

Thanks to Xavier Bachelot for his help.

#2

Updated by Benjamin Dauvergne over 2 years ago

  • Tracker changed from Support to Bug
  • Status changed from Nouveau to Solution validée
#3

Updated by Benjamin Dauvergne over 2 years ago

  • Status changed from Solution validée to Résolu (à déployer)
#4

Updated by Benjamin Dauvergne over 2 years ago

commit f6f76b4d0cbf9b17239a01979d94607ae9763f80
Author: Benjamin Dauvergne <bdauvergne@entrouvert.com>
Date:   Tue Aug 11 15:35:56 2020 +0200

    configure.ac: support php7 interpreter on CentOS 8 (#42299)

#5

Updated by Benjamin Dauvergne over 1 year ago

  • Status changed from Résolu (à déployer) to Fermé

Also available in: Atom PDF