Project

General

Profile

Development #55558

[Connecteur MDEL] Typos sur les informations du payload

Added by Marie Kuntz 3 months ago. Updated about 2 months ago.

Status:
Solution déployée
Priority:
Normal
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Patch proposed:
Yes
Planning:
No

Description

Dans le payload du connecteur, dans la section §AEC-LA PAYLOAD
  • titulaire_civilite n'est pas mentionné mais est obligatoire
  • demandeur_prenom*s* est mentionné mais c'est demandeur_prenom qui est attendu
  • display_id n'est pas mentionné mais est obligatoire
  • nombre_exemplaire est mentionné mais c'est nombre_exemplaire*s* qui est attendu

Files

Associated revisions

Revision 80124969 (diff)
Added by Benjamin Dauvergne 2 months ago

mdel: fix typo and missing fields in schema description (#55558)

History

#1

Updated by Benjamin Dauvergne 3 months ago

Pour display_id il me semble que c'est fait pour envoyer tout le formulaire (et il doit y avoir un formulaire type quelque part), pas gérer l'appel à la main.

#2

Updated by Benjamin Dauvergne 3 months ago

  • Assignee set to Benjamin Dauvergne
#3

Updated by Benjamin Dauvergne 3 months ago

#4

Updated by Marie Kuntz 3 months ago

Benjamin Dauvergne a écrit :

Pour display_id il me semble que c'est fait pour envoyer tout le formulaire (et il doit y avoir un formulaire type quelque part), pas gérer l'appel à la main.

Dans les exemples que j'ai vu, display_id prend {{form_number}}

#5

Updated by Benjamin Dauvergne 3 months ago

Clairement le code suppose qu'on pousse tout le formulaire avec l'option "Envoyer les données du formulaire" mais oui tu peux mettre {{ form_number }} dans display_id c'est pareil (avec l'option ça envoie tout ça automatiquement). De toute façon mon patch contient l'ajout de display_id à la liste.

#6

Updated by Thomas Noël (congés → 11 octobre) 3 months ago

Il fait tout bizarre ce display_id ... normalement il n'a pas à être rempli manuellement, Marie (c'est totomatique)... est-ce qu'il y a un endroit où tu le fait, un appel webservice qu'on peut voir quelque part pour comprendre ce paramètre ?

#7

Updated by Benjamin Dauvergne 3 months ago

J'ai ajouté les caractères '*' qui indique je crois que c'est obligatoire.

#8

Updated by Marie Kuntz 3 months ago

Thomas Noël a écrit :

Il fait tout bizarre ce display_id ... normalement il n'a pas à être rempli manuellement, Marie (c'est totomatique)... est-ce qu'il y a un endroit où tu le fait, un appel webservice qu'on peut voir quelque part pour comprendre ce paramètre ?

Ben j'ai commencé par ne pas le mettre et le connecteur a gueulé que c'était obligatoire...

Je ne coche pas "Envoyer les données du formulaire".

#12

Updated by Thomas Noël (congés → 11 octobre) 2 months ago

  • Status changed from Solution proposée to Solution validée
#13

Updated by Benjamin Dauvergne 2 months ago

  • Status changed from Solution validée to Résolu (à déployer)
commit 80124969b3cbb2718e408cd5fd550d7339533f16
Author: Benjamin Dauvergne <bdauvergne@entrouvert.com>
Date:   Tue Jul 13 13:33:21 2021 +0200

    mdel: fix typo and missing fields in schema description (#55558)
#14

Updated by Frédéric Péters about 2 months ago

  • Status changed from Résolu (à déployer) to Solution déployée

Also available in: Atom PDF