Project

General

Profile

Development #59926

Installation passerelle dans Bullseye

Added by Guillaume Baffoin 6 months ago. Updated 4 months ago.

Status:
Fermé
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
20 Dec 2021
Due date:
% Done:

0%

Estimated time:
Patch proposed:
No
Planning:
No

Description

apt install passerelle
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 python3-passerelle : Dépend: python3-cmislib mais il n'est pas installable
                      Dépend: python3-crypto mais il n'est pas installable
                      Dépend: python3-pdfrw mais il n'est pas installable
                      Dépend: python3-pyexcel-io mais il n'est pas installable
                      Dépend: python3-pyexcel-ods mais il n'est pas installable
                      Dépend: python3-pyexcel-xls mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

python3-crypto semble remplacer par python3-pycryptodome
pour le reste je n'ai pas recherché de remplacant.

History

#1

Updated by Frédéric Péters 6 months ago

Faut préciser à coups de apt install la-dépendance pour avoir module par module la raison.

#2

Updated by Guillaume Baffoin 6 months ago

Là, les paquets n'existent pas. C'est explicite.
par contre il faut trouver la solution de contournement...

#3

Updated by Frédéric Péters 6 months ago

Il n'y a rien dans python3-cmislib mais il n'est pas installable qui dit que c'est parce que le paquet n'existe pas. (il peut exister mais avec une une version pas ok, ou une dépendance qui n'exite pas, ou avec une version pas ok, etc.).

#4

Updated by Guillaume Baffoin 4 months ago

rencontrer aujourd'hui au cd31.
il n'y a que python3-crypto qui bloque

sudo apt install passerelle
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 python3-crypto : Dépend: python3 (< 3.8) mais 3.9.2-3 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

#5

Updated by Paul Marillonnet 4 months ago

Pas vu que tu avais déjà poussé une branche. Mes excuses :/

Est-ce que tu peux aussi retirer la dépendance correspondante (pycrypto) dans le setup.py stp ?

#6

Updated by Guillaume Baffoin 4 months ago

j'ai mis à jour wip/59926-dependency en enlevant pycrypto.

#7

Updated by Paul Marillonnet 4 months ago

  • Status changed from Nouveau to Solution validée

Top.

#8

Updated by Guillaume Baffoin 4 months ago

  • Status changed from Solution validée to Solution déployée

installé en recette sur cd31

#10

Updated by Transition automatique 2 months ago

Automatic expiration

Also available in: Atom PDF