Project

General

Profile

Bug #69471

module ldap incompatible avec Debian 10 (python 3.7)

Added by Thomas Noël 6 days ago. Updated 6 days ago.

Status:
Solution déployée
Priority:
Normal
Assignee:
Target version:
-
Start date:
23 September 2022
Due date:
% Done:

0%

Estimated time:
Patch proposed:
Yes
Planning:
No

Description

Et crash :

  File "/usr/lib/python3/dist-packages/passerelle/apps/ldap/models.py", line 377
    def get(self, key, default=None, /):
                                     ^
SyntaxError: invalid syntax

Files

History

#2

Updated by Thomas Noël 6 days ago

#3

Updated by Frédéric Péters 6 days ago

  • Status changed from Solution proposée to Solution validée
#4

Updated by Thomas Noël 6 days ago

  • Status changed from Solution validée to Résolu (à déployer)
commit 2cb2eb1c18ca31f186955fdee711e6df8a87eef0
Author: Thomas NOËL <tnoel@entrouvert.com>
Date:   Fri Sep 23 01:57:48 2022 +0200

    ldap: remove slash in function parameters (pep 570 not in python 3.7) (#/69471)

#5

Updated by Thomas Noël 6 days ago

  • Status changed from Résolu (à déployer) to Solution déployée

Typo dans le code du numéro de ticket dans le commit, je ferme à la main.

Also available in: Atom PDF