Project

General

Profile

Bug #7365

fix import of flatten_fieldsets with django < 1.7

Added by Benjamin Dauvergne about 9 years ago. Updated about 9 years ago.

Status:
Fermé
Priority:
Normal
Category:
-
Target version:
Start date:
26 May 2015
Due date:
% Done:

0%

Estimated time:
Patch proposed:
No
Planning:

Description

  File "/home/bdauvergne/.virtualenvs/authentic/local/lib/python2.7/site-packages/django/utils/importlib.py", line 40, in import_module
    __import__(name)
  File "/home/bdauvergne/Code/authentic2/src/authentic2/admin.py", line 14, in <module>
    from django.contrib.admin.utils import flatten_fieldsets
ImportError: No module named utils

django.contrib.admin.util was renamed as django.contrib.admin.utils in Django 1.7.0. For pre 2.2.x release, we must support the old path.

Associated revisions

Revision 1086a211 (diff)
Added by Benjamin Dauvergne about 9 years ago

admin: import flatten_fieldsets() from django.contrib.admin.util for pre Django 1.7 compatibility

fixes #7365

History

#1

Updated by Benjamin Dauvergne about 9 years ago

  • Status changed from Nouveau to Fermé

Also available in: Atom PDF