Project

General

Profile

Bug #92187

Bouton d'action dans les cellules fiche(s) : ne fonctionne pas avec le mode d'affichage carte

Added by Pierre Cros (congés jusqu'au 26/07) about 1 month ago. Updated 26 days ago.

Status:
Solution déployée
Priority:
Normal
Target version:
-
Start date:
24 June 2024
Due date:
% Done:

0%

Estimated time:
Patch proposed:
No
Planning:
No

Description

Cette cellule Fiche(s)
https://validation.test.entrouvert.org/manage/pages/54/#open:wcs_wcscardcell-35-display. L

Cette action globale avec déclencheur externe
https://demarches-validation.test.entrouvert.org/backoffice/workflows/90/global-actions/1/

Tout fonctionne comme il faut si on personnalise le mode d'affichage tableau, on peut ajouter un élément action.

Mais avec le mode d'affichage carte, quand on enregistre l'élément "action" que l'on vient de configurer, il se transforme en élément "personnalisé", la configuration disparaît.

Associated revisions

Revision 4dacd282 (diff)
Added by Lauréline Guérin 27 days ago

wcs: fix action button config for card display mode (#92187)

History

#2

Updated by Anaïs Ecuvillon 27 days ago

Arles rencontre le même souci :

impossible de mettre un bouton d'action en mode affichage personnalisé carte, cela switche immédiatement en "personnalisé", sans garder le contenu ni afficher le bouton.

Il rajoute :

cela ne marche qu'à moitié en mode d'affichage "tableau" aussi : le "action" reste activé, le bouton est visible, mais en cliquant sur "modifier", cela bascule en mode "personnalisé", même si la configuration est sauvegardée.

Est-ce que c'est le comportement attendu ou bien un bug qui va être résolu ?

#3

Updated by Corentin Séchet 27 days ago

impossible de mettre un bouton d'action en mode affichage personnalisé carte, cela switche immédiatement en "personnalisé", sans garder le contenu ni afficher le bouton.

Le cas d'usage n'a pas été prévu.

cela ne marche qu'à moitié en mode d'affichage "tableau" aussi : le "action" reste activé, le bouton est visible, mais en cliquant sur "modifier", cela bascule en mode "personnalisé", même si la configuration est sauvegardée.

C'est un autre bug, j'ai entré https://dev.entrouvert.org/issues/92350. Je traiterai ces deux tickets courant Juillet, plus https://dev.entrouvert.org/issues/90770.

#4

Updated by Robot Gitea 27 days ago

  • Status changed from Nouveau to En cours
  • Assignee changed from Corentin Séchet to Lauréline Guérin

Lauréline Guérin (lguerin) a ouvert une pull request sur Gitea concernant cette demande :

#5

Updated by Robot Gitea 27 days ago

  • Status changed from En cours to Solution proposée
#6

Updated by Robot Gitea 27 days ago

  • Status changed from Solution proposée to Solution validée

Corentin Sechet (csechet) a approuvé une pull request sur Gitea concernant cette demande :

#7

Updated by Robot Gitea 26 days ago

  • Status changed from Solution validée to Résolu (à déployer)

Lauréline Guérin (lguerin) a mergé une pull request sur Gitea concernant cette demande :

#8

Updated by Transition automatique 26 days ago

  • Status changed from Résolu (à déployer) to Solution déployée

Also available in: Atom PDF